This repository has been archived on 2024-07-25. You can view files and clone it, but cannot push or open issues or pull requests.
picsg/flake.nix

48 lines
1.1 KiB
Nix

{
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
hPkgs = pkgs.haskellPackages;
myDevTools = with hPkgs; [
ghc
ghcid
ormolu
hlint
hoogle
haskell-language-server
implicit-hie
retrie
];
picsg = pkgs.haskellPackages.developPackage {
root = ./.;
};
in
{
packages = {
default = picsg;
picsg = picsg;
docker = pkgs.dockerTools.buildImage {
name = "picgs";
config = {
Cmd = [ "${picsg}/bin/picsg" ];
};
};
};
devShells.default = pkgs.mkShell {
buildInputs = myDevTools ++ [ hPkgs.cabal-install ];
LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath myDevTools;
};
});
}